re = /\\([^\\]*)(?:,|$)/
str = '\\\\lorem\\ipsum\\dolor,\\\\sit\\amet\\conseteteur,\\\\sadipscing\\elitr\\sed\\diam'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end