re = /https:\/\/[^\s^\]]+/m
str = '[https://development-client.test.app/users/reset-password?email=test.test%40inbox.testmail.app&code=98f192b1-5673-45b5-b498-d55a4ba3345]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end