// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)https:\/\/[^\s^\]]+").unwrap();
let string = "[https://development-client.test.app/users/reset-password?email=test.test%40inbox.testmail.app&code=98f192b1-5673-45b5-b498-d55a4ba3345]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}