$re = '/^(ISA.*?(?=ESA)ESA.)(ISA.*?(?=ESA)ESA.)$/';
$str = 'ISA~this is date~ESA|ISA~this is more data~ESA|';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);