re = /^(ISA.*?(?=ESA)ESA.)(ISA.*?(?=ESA)ESA.)$/
str = 'ISA~this is date~ESA|ISA~this is more data~ESA|'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end