$re = '/(?|([aeiou]+)[0-9]+|([123]+)[a-z]+)\W+/m';
$str = 'ae123.
111abc!
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);