package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+$)`)
var str = `12345crn_rrk_t123.@1234jmf.121d`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}