re = /(^[a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+$)/m
str = '12345crn_rrk_t123.@1234jmf.121d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end