$re = '/^([!@#$%^&*]+|\d+|[a-zA-Z]+)$/m';
$str = 'aaa
123
@#$
a12qw
a@s
123$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);