use strict;
my $str = '005
0AB
000
0';
my $regex = qr/^0*(.+)$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";