$re = '/^0*(.+)$/m';
$str = '005
0AB
000
0';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;