const regex = /(?<!\bbad\b[^.\n]*)\bgood\b(?![^.\n]+\bbad\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\bbad\\b[^.\\n]*)\\bgood\\b(?![^.\\n]+\\bbad\\b)', 'gm')
const str = `A good example of a bad regex.
A bad example of a good regex.
A bad example. A good regex.
A good example. A bad regex.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}