re = /(?<!\bbad\b[^.\n]*)\bgood\b(?![^.\n]+\bbad\b)/m
str = 'A good example of a bad regex.
A bad example of a good regex.
A bad example. A good regex.
A good example. A bad regex.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end