import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A.+\\z|\\A[\\s\\S]*\\n\\K.+\\z";
final String string = "Line1: ABCDEF\n"
+ "Line2: GHIJKL\n"
+ "Line3: MNOPQR\n"
+ "Line4: STUVWX\n"
+ "Line5: YZ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}