$re = '/\A.+\z|\A[\s\S]*\n\K.+\z/';
$str = 'Line1: ABCDEF
Line2: GHIJKL
Line3: MNOPQR
Line4: STUVWX
Line5: YZ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);