#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)var\s?_u='(.*)';var\s?_i='\d+'"
Local $sString = "<script nonce="0Riv3mh5Oi2oiInM7K0krg">(function(){var _u='https://encrypted-tbn0.gstatic.com/shopping?q\x3dtbn:ANd9GcSnFEFIYwW9_wynoYlTURQHjGn5RoMtatIFKVxt1QBUCXK1PI34MGJNHwp6ejHXWpNMjmISleVQFeqe7Wu4O6tNKMjM3McKxGK8oR8YWr9XZN4gEHdWlWHVcw\x26usqp\x3dCAE';var _i='2399509046500065955';_setImagesSrc([_i],_u);})();</script>" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")