import re
regex = re.compile(r"var\s?_u='(.*)';var\s?_i='\d+'", flags=re.MULTILINE)
test_str = ("<script nonce=\"0Riv3mh5Oi2oiInM7K0krg\">(function(){var _u='https://encrypted-tbn0.gstatic.com/shopping?q\\x3dtbn:ANd9GcSnFEFIYwW9_wynoYlTURQHjGn5RoMtatIFKVxt1QBUCXK1PI34MGJNHwp6ejHXWpNMjmISleVQFeqe7Wu4O6tNKMjM3McKxGK8oR8YWr9XZN4gEHdWlWHVcw\\x26usqp\\x3dCAE';var _i='2399509046500065955';_setImagesSrc([_i],_u);})();</script>\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")