package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\d]{1,2}(\.([\d]{1,3}))?)$|^(100(\.0{1,3})?)$ `)
var str = `100.0000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}