$re = '/^([\d]{1,2}(\.([\d]{1,3}))?)$|^(100(\.0{1,3})?)$ /m';
$str = '100.0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);