using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[(]{1}[0-9]{2,3}[)]{1}([0-9]){4,5}(-?)([0-9]{4})";
string input = @"(031)985702237";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}