$re = '/^[(]{1}[0-9]{2,3}[)]{1}([0-9]){4,5}(-?)([0-9]{4})/';
$str = '(031)985702237';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);