import re
regex = re.compile(r"^[\s;]+(?<![^\s;])|(?<=;)[\s;]*|(?<=[^\s;])\s*|(?![^\s;])[\s;]+$", flags=re.MULTILINE)
test_str = ";; ; a; b ; c;;;d ; ; ; e; ;"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)