re = /^[\s;]+(?<![^\s;])|(?<=;)[\s;]*|(?<=[^\s;])\s*|(?![^\s;])[\s;]+$/m
str = ';; ; a; b ; c;;;d ; ; ; e; ;'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result