const regex = /(^\040*)(\w*)(\040*)(=)(\040*)(\w*$|".*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\040*)(\\w*)(\\040*)(=)(\\040*)(\\w*$|".*)', 'gm')
const str = `# '#' character is used for comments - like in Bash
# '*' character is a wildcart character, ".*" is the regex equivalence
# set x-ambles, the strings to be printed before, in-between and after the group of bitfields
preamble="#ifdef DEBUG"
interamble=#else
postamble=#endif
# set the alignment value
alignment=16
# bitfield names to be ignored
ignore=padding*,dummy*,doNotCare*
# indent
indent=" "
# padding type
padding = unsigned
# this whould not be searched by C++ engine
files=*.h,*.c
#prefix of type name to be searched
prefix=typedef
#do or do not mirror
mirror=true
#for regex testig
mirror=\$
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}