use strict;
my $str = '# \'#\' character is used for comments - like in Bash
# \'*\' character is a wildcart character, ".*" is the regex equivalence
# set x-ambles, the strings to be printed before, in-between and after the group of bitfields
preamble="#ifdef DEBUG"
interamble=#else
postamble=#endif
# set the alignment value
alignment=16
# bitfield names to be ignored
ignore=padding*,dummy*,doNotCare*
# indent
indent=" "
# padding type
padding = unsigned
# this whould not be searched by C++ engine
files=*.h,*.c
#prefix of type name to be searched
prefix=typedef
#do or do not mirror
mirror=true
#for regex testig
mirror=$
';
my $regex = qr/(^\040*)(\w*)(\040*)(=)(\040*)(\w*$|".*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}