$re = '~(?:(\((?:[^()]++|(?1))*\))|\'[^\']*\')(*SKIP)(*F)|([+\-*/^])~m';
$str = '1 + 2 * (3 + (23 + 53 - (132 / 5) + 5) - 1) + 2 / \'test + string\' - 52
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);