#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\([+-]?(?!0)(\d)+(\.\d+)?,\s[+-]?(?!0)(\d)+(\.\d+)?\)"
Local $sString = "(3420.34, 432)" & @CRLF & _
"(+342.32, 432)" & @CRLF & _
"(-342.5, 432)" & @CRLF & _
"(0342.23, 432)" & @CRLF & _
"(342., 432)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")