const regex = /\([+-]?(?!0)(\d)+(\.\d+)?,\s[+-]?(?!0)(\d)+(\.\d+)?\)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\([+-]?(?!0)(\\d)+(\\.\\d+)?,\\s[+-]?(?!0)(\\d)+(\\.\\d+)?\\)', 'mg')
const str = `(3420.34, 432)
(+342.32, 432)
(-342.5, 432)
(0342.23, 432)
(342., 432)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}