using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:([^:\r\n]+):\W*)?([^;\r\n]+)(?:;\W*(.+))?";
string input = @"Mr: Smith
Mr: Smith; John
Smith
Smith; John
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}