$re = '/^(?:([^:\r\n]+):\W*)?([^;\r\n]+)(?:;\W*(.+))?/m';
$str = 'Mr: Smith
Mr: Smith; John
Smith
Smith; John
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);