# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\w'-]+(diagnosis)/_\1/gm;t' <<< "Some other medical terms and stuff diagnosis of R45.2 was entered for this patient. Where did Doctor Who go? Then xxx feea fdsfd
"