use strict;
my $str = 'Some other medical terms and stuff diagnosis of R45.2 was entered for this patient. Where did Doctor Who go? Then xxx feea fdsfd
';
my $regex = qr/[^\w'-]+(diagnosis)/mp;
my $subst = '_\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";