#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?<!\d[,.])(?<!\d-)((?:\d+/)?\d+(?:[,.]\d+)*)\b(\s*(\w*)/)?\s*((?(2)\w+|\w+\s+per\s+\w+))(?=\s*(?:[,)]|$))"
Local $sString = "3M™ Victory Series™ Bracket MBT™ 017-873, .022, UL3, 0T/8A, Hk, 5/Pack" & @CRLF & _
" 5/Pack" & @CRLF & _
"3M™ BX™ Dual Reader Protective Eyewear 11458-00000-20, Clear Anti-Fog Lens, Silver/Black Frame, +2.0 Top/Bottom Diopter, 20 ea/Case" & @CRLF & _
" 20 ea/Case" & @CRLF & _
"4220VDS-QCSHC/900-000/A CABINET EMPTY" & @CRLF & _
" No units" & @CRLF & _
"3M™ Bumpon™ Protective Product SJ5476 Fluorescent Yellow, 3.000/Case" & @CRLF & _
" 3.000/Case" & @CRLF & _
"3M™ Bumpon™ Protective Products SJ61A2 Black, 10,000/Case" & @CRLF & _
" 10,000/Case" & @CRLF & _
"" & @CRLF & _
"QWERTYUI PN-DR, Coarse, TR, 1-1/2 in, 50/Carton, 200 ea/Case, Dispenser Pack" & @CRLF & _
" 50/Carton, 200 ea/Case" & @CRLF & _
"2841 PC GREY AS/AF (20/CASE)" & @CRLF & _
" 20/CASE" & @CRLF & _
"TYPE.2 86421-K40-F000, 1 Set/Pack, 100 Packs/Case" & @CRLF & _
" 1 Set/Pack, 100 Packs/Case" & @CRLF & _
"RTYU 31655, 240+, 6 in, 50 Discs/Roll, 6 Rolls/Case" & @CRLF & _
" 50 Discs/Roll, 6 Rolls/Case" & @CRLF & _
"Clear, 1 in x 36 yd, 4.8 mil, 24 rolls per case" & @CRLF & _
" 24 rolls per case" & @CRLF & _
"3M™ Victory Series™ Bracket MBT™ 017-873, .022, UL3, 0T/8A, Hk, 5/Pack" & @CRLF & _
" 5/Pack" & @CRLF & _
"3M™ BX™ Dual Reader Protective Eyewear 11458-00000-20, Clear Anti-Fog Lens, Silver/Black Frame, +2.0 Top/Bottom Diopter, 20 ea/Case" & @CRLF & _
" 20 ea/Case" & @CRLF & _
"4220VDS-QCSHC/900-000/A CABINET EMPTY" & @CRLF & _
" No units" & @CRLF & _
"3M™ Bumpon™ Protective Product SJ5476 Fluorescent Yellow, 3.000/Case" & @CRLF & _
" 3.000/Case" & @CRLF & _
"3M™ Bumpon™ Protective Products SJ61A2 Black, 10,000/Case" & @CRLF & _
" 10,000/Case"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")