use strict;
my $str = '3M™ Victory Series™ Bracket MBT™ 017-873, .022, UL3, 0T/8A, Hk, 5/Pack
5/Pack
3M™ BX™ Dual Reader Protective Eyewear 11458-00000-20, Clear Anti-Fog Lens, Silver/Black Frame, +2.0 Top/Bottom Diopter, 20 ea/Case
20 ea/Case
4220VDS-QCSHC/900-000/A CABINET EMPTY
No units
3M™ Bumpon™ Protective Product SJ5476 Fluorescent Yellow, 3.000/Case
3.000/Case
3M™ Bumpon™ Protective Products SJ61A2 Black, 10,000/Case
10,000/Case
QWERTYUI PN-DR, Coarse, TR, 1-1/2 in, 50/Carton, 200 ea/Case, Dispenser Pack
50/Carton, 200 ea/Case
2841 PC GREY AS/AF (20/CASE)
20/CASE
TYPE.2 86421-K40-F000, 1 Set/Pack, 100 Packs/Case
1 Set/Pack, 100 Packs/Case
RTYU 31655, 240+, 6 in, 50 Discs/Roll, 6 Rolls/Case
50 Discs/Roll, 6 Rolls/Case
Clear, 1 in x 36 yd, 4.8 mil, 24 rolls per case
24 rolls per case
3M™ Victory Series™ Bracket MBT™ 017-873, .022, UL3, 0T/8A, Hk, 5/Pack
5/Pack
3M™ BX™ Dual Reader Protective Eyewear 11458-00000-20, Clear Anti-Fog Lens, Silver/Black Frame, +2.0 Top/Bottom Diopter, 20 ea/Case
20 ea/Case
4220VDS-QCSHC/900-000/A CABINET EMPTY
No units
3M™ Bumpon™ Protective Product SJ5476 Fluorescent Yellow, 3.000/Case
3.000/Case
3M™ Bumpon™ Protective Products SJ61A2 Black, 10,000/Case
10,000/Case';
my $regex = qr/\b(?<!\d[,.])(?<!\d-)((?:\d+/)?\d+(?:[,.]\d+)*)\b(\s*(\w*)/)?\s*((?(2)\w+|\w+\s+per\s+\w+))(?=\s*(?:[,)]|$))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}