import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!foo)bar(?!.*foo).*";
final String string = "bar //true\n"
+ ",bar, //true\n"
+ ",,bar,, //true\n"
+ "barbar //true\n"
+ ",bar,bar, //true\n"
+ ",,bar,,bar,, //true\n"
+ "barbarbar //true\n"
+ ",bar,bar,bar, //true\n"
+ ",,bar,,bar,,bar,, //true\n\n"
+ "foo //false\n"
+ ",foo, //false\n"
+ ",,foo,, //false\n"
+ "foobar //false\n"
+ ",foo,bar, //false\n"
+ ",,foo,,bar,, //false\n"
+ "barfoo //false\n"
+ ",bar,foo, //false\n"
+ ",,bar,,foo,, //false\n"
+ "foofoo //false\n"
+ ",foo,foo, //false\n"
+ ",,foo,,foo,, //false\n"
+ "foobarbar //false\n"
+ ",foo,bar,bar, //false\n"
+ ",,foo,,bar,,bar,, //false\n"
+ "barfoobar //false\n"
+ ",bar,foo,bar, //false\n"
+ ",,bar,,foo,,bar,, //false\n"
+ "barbarfoo //false\n"
+ ",bar,bar,foo, //false\n"
+ ",,bar,,bar,,foo,, //false\n"
+ "barfoofoo //false\n"
+ ",bar,foo,foo, //false\n"
+ ",,bar,,foo,,foo,, //false\n"
+ "foobarfoo //false\n"
+ ",foo,bar,foo, //false\n"
+ ",,foo,,bar,,foo,, //false\n"
+ "foofoobar //false\n"
+ ",foo,foo,bar, //false\n"
+ ",,foo,,foo,,bar,, //false\n"
+ "foofoofoo //false\n"
+ ",foo,foo,foo, //false\n"
+ ",,foo,,foo,,foo,, //false";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}