# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!foo)bar(?!.*foo).*"
test_str = ("bar //true\n"
",bar, //true\n"
",,bar,, //true\n"
"barbar //true\n"
",bar,bar, //true\n"
",,bar,,bar,, //true\n"
"barbarbar //true\n"
",bar,bar,bar, //true\n"
",,bar,,bar,,bar,, //true\n\n"
"foo //false\n"
",foo, //false\n"
",,foo,, //false\n"
"foobar //false\n"
",foo,bar, //false\n"
",,foo,,bar,, //false\n"
"barfoo //false\n"
",bar,foo, //false\n"
",,bar,,foo,, //false\n"
"foofoo //false\n"
",foo,foo, //false\n"
",,foo,,foo,, //false\n"
"foobarbar //false\n"
",foo,bar,bar, //false\n"
",,foo,,bar,,bar,, //false\n"
"barfoobar //false\n"
",bar,foo,bar, //false\n"
",,bar,,foo,,bar,, //false\n"
"barbarfoo //false\n"
",bar,bar,foo, //false\n"
",,bar,,bar,,foo,, //false\n"
"barfoofoo //false\n"
",bar,foo,foo, //false\n"
",,bar,,foo,,foo,, //false\n"
"foobarfoo //false\n"
",foo,bar,foo, //false\n"
",,foo,,bar,,foo,, //false\n"
"foofoobar //false\n"
",foo,foo,bar, //false\n"
",,foo,,foo,,bar,, //false\n"
"foofoofoo //false\n"
",foo,foo,foo, //false\n"
",,foo,,foo,,foo,, //false")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.