package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\s*ins[^>]*>([^<]*)<\s*\/\s*ins\s*>`)
var str = `<ins>
sdf
sdf
sdf
</ins>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}