package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`mr abdul alim m2a`)
var str = `ça va?`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}