package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w+=([\w\s]*.*?)[,\]]`)
var str = `id=9, district=, name=OMG LTD,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}