$re = '/\w+=([\w\s]*.*?)[,\]]/';
$str = 'id=9, district=, name=OMG LTD,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);