package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*?)-(\d.*)\.\w+`)
var str = `my-file-name-0.44.0.6-SOME-SNAPSHOT.zip
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}