$re = '/(.*?)-(\d.*)\.\w+/';
$str = 'my-file-name-0.44.0.6-SOME-SNAPSHOT.zip
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);