import re
regex = re.compile(r"(«[a-z])")
test_str = "«el taller del traductor\""
subst = "\\U$1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)