using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"API: START: \/v1\/expense\/extract\/demand\/(?<app>[^\/]+)\/(?<OnDemandFileName>.*)";
string input = @"API: START: /v1/expense/extract/demand/nagl/demand_con.csv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}