re = /API: START: \/v1\/expense\/extract\/demand\/(?<app>[^\/]+)\/(?<OnDemandFileName>.*)/m
str = 'API: START: /v1/expense/extract/demand/nagl/demand_con.csv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end