#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b(?:Units?|Shops?|Offices?|Flats?|Rm|Rooms?|Suites?)[^,\r\n]+"
Local $sString = "Rm. 2301, Blk. B3-B4, " & @CRLF & _
"Flat/Room 5, 9/F, " & @CRLF & _
"rm A, 17/F., " & @CRLF & _
"Flat F, 9/F, " & @CRLF & _
"Flat G1, 10/F, " & @CRLF & _
"Flat C, 36/F, Block 1, " & @CRLF & _
"Flat 1107&1108, 11/F, " & @CRLF & _
"Flat 2301, 23/F, F" & @CRLF & _
"Unit 3, 2/F, L" & @CRLF & _
"Unit 1603 16/F " & @CRLF & _
"Offices D-F, 23/F, " & @CRLF & _
"Office D-F, 23/F, " & @CRLF & _
"Unit 1901, 19/F, " & @CRLF & _
"Units A, 6/F, " & @CRLF & _
"Shop 14, G/F, " & @CRLF & _
"Rooms 2202, " & @CRLF & _
"Suite 702, 7/F.," & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")