use strict;
my $str = 'Rm. 2301, Blk. B3-B4,
Flat/Room 5, 9/F,
rm A, 17/F.,
Flat F, 9/F,
Flat G1, 10/F,
Flat C, 36/F, Block 1,
Flat 1107&1108, 11/F,
Flat 2301, 23/F, F
Unit 3, 2/F, L
Unit 1603 16/F
Offices D-F, 23/F,
Office D-F, 23/F,
Unit 1901, 19/F,
Units A, 6/F,
Shop 14, G/F,
Rooms 2202,
Suite 702, 7/F.,
';
my $regex = qr/\b(?:Units?|Shops?|Offices?|Flats?|Rm|Rooms?|Suites?)[^,\r\n]+/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}