$re = '/\w+-(?<your_field>.*)/m';
$str = 'abc-ec-1
xyz-ec-01
pqr-ec01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);