package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:\D\d)+\D`)
var str = `H1e2l3l1o Hello Hel1lo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}