$re = '~\b(?:\D\d)+\D~';
$str = 'H1e2l3l1o Hello Hel1lo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);